# VuePress アップデート

VuePress1.0.0-alpha.32 から、 1.0.0-alpha.39 にアップデートしました。

# 前回のアップデート

# バージョン確認

# npm でインストールしたパッケージのバージョンを確認

$ npm list --depth=0
hene@1.0.0 /Users/xxxxx/hene
├── @vuepress/plugin-blog@1.0.0-alpha.0
├── @vuepress/plugin-google-analytics@1.0.0-alpha.0
├── node-sass@4.11.0
├── pug@2.0.3
├── pug-plain-loader@1.0.0
├── sass-loader@7.1.0
└── vuepress@1.0.0-alpha.32

# 古くなったバッケージのバージョンを確認

VuePress の新しいバージョンがでているのを確認。

$ npm outdated
Package Current Wanted Latest Location
vuepress 1.0.0-alpha.32 1.0.0-alpha.39 0.14.9 hene

# VuePress アップデート

# アップデート

$ npm update -D vuepress
npm WARN deprecated browserslist@2.11.3: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.

> fsevents@1.2.7 install /Users/xxxxx/hene/node_modules/fsevents
> node install

node-pre-gyp WARN Using request for node-pre-gyp https download
[fsevents] Success: "/Users/xxxxx/hene/node_modules/fsevents/lib/binding/Release/node-v57-darwin-x64/fse.node" is installed via remote
npm WARN ajv-keywords@3.4.0 requires a peer of ajv@^6.9.1 but none is installed. You must install peer dependencies yourself.
npm WARN hene@1.0.0 No repository field.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: idb-connector@1.1.8 (node_modules/idb-connector):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for idb-connector@1.1.8: wanted {"os":"aix","arch":"any"} (current: {"os":"darwin","arch":"x64"})

- vuepress@1.0.0-alpha.39
  added 171 packages from 111 contributors, removed 173 packages, updated 102 packages, moved 22 packages and audited 18015 packages in 53.172s
  found 0 vulnerabilities

# アップデートの確認

$ git diff package.json
diff --git a/package.json b/package.json
index 7c3b63e..2e0f674 100644
--- a/package.json
+++ b/package.json
@@ -17,6 +17,6 @@
"pug": "^2.0.3",
"pug-plain-loader": "^1.0.0",
"sass-loader": "^7.1.0",
- "vuepress": "^1.0.0-alpha.32"
+ "vuepress": "^1.0.0-alpha.39"
  }
}

# node_modules

# node_modules 以下を削除

$ rm -rf node_modules/

# node_modules 以下入れ直し

$ npm i

> fsevents@1.2.7 install /Users/xxxxx/hene/node_modules/fsevents
> node install

node-pre-gyp WARN Using request for node-pre-gyp https download
[fsevents] Success: "/Users/xxxxx/hene/node_modules/fsevents/lib/binding/Release/node-v57-darwin-x64/fse.node" is installed via remote

> node-sass@4.11.0 install /Users/xxxxx/hene/node_modules/node-sass
> node scripts/install.js

Cached binary found at /Users/xxxxx/.npm/node-sass/4.11.0/darwin-x64-57_binding.node

> node-sass@4.11.0 postinstall /Users/xxxxx/hene/node_modules/node-sass
> node scripts/build.js

Binary found at /Users/xxxxx/hene/node_modules/node-sass/vendor/darwin-x64-57/binding.node
Testing binary
Binary is fine
npm WARN hene@1.0.0 No repository field.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: idb-connector@1.1.8 (node_modules/idb-connector):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for idb-connector@1.1.8: wanted {"os":"aix","arch":"any"} (current: {"os":"darwin","arch":"x64"})

added 1388 packages from 735 contributors and audited 18015 packages in 31.011s
found 0 vulnerabilities

入れ直すと、下記の WARN は消えた。

npm WARN ajv-keywords@3.4.0 requires a peer of ajv@^6.9.1 but none is installed. You must install peer dependencies yourself.

# その他

問題なさそうなので、とりあえずそのままにしておいた。

npm WARN hene@1.0.0 No repository field.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: idb-connector@1.1.8 (node_modules/idb-connector):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for idb-connector@1.1.8: wanted {"os":"aix","arch":"any"} (current: {"os":"darwin","arch":"x64"})

# 参考